eclipse配置pydev解释器

2019-12-05 21:51栏目:龙竞技官网
TAG:

1、eclipse->windows->preferences

竞技宝app,python3 与 python2 的多版本共存(Linux),python3python2

python3已经出来有些许时候了,python3相比python2进行了大量的改进,包括语法,新的功能,还有优化。虽然很多库已经同时支持 python2和python3了,但是有些库仍然没有很好的支持python3,因此有时我们还是需要使用python2。   笔者是在去年开始学python的,作为没有历史包袱的初学者,当时自然而然的选则了python3来进行学习,但是在安装了新的python3后,新安装的python3不可避免的与系统自带的python2产生了一些冲突。包括不同版本的调用,不同版本的python库安装工具(pip,easy_install)。   本文就python2和pyhon3共存的环境进行了说明,包括python3的安装,pip的安装,以及如何调用这两种python版本。  

CentOS7安装Python3

竞技宝客户端,CentOS7默认安装了python2.7.5,当需要使用python3的时候,可以手动下载python源码后编译安装。

  1. 下载python()
  2. 解压下载好的压缩包
  3. sudo mkdir /usr/local/python3
    进入解压目录sudo ./configure --prefix=/usr/local/python3
  4. 竞技宝手机版app官网,sudo make
  5. 竞技宝电竞,竞技宝手机版官网,竞技宝,sudo make install
  6. 竞技宝平台,在/usr/bin中有python、python2、python2.7三个文件依次指向后者,我们将python备份(sudo mv python python.bak),然后创建python3的软链接(sudo ln -s /usr/local/python3/bin/python3 /usr/bin/python)。这样默认的python版本就替换为python3了。
  7. 因为yum使用python2,因此替换为python3后可能无法正常工作,因此修改yum配置文件(sudo vi /usr/bin/yum)。
    将第一行指定的python版本改为python2.7(#!/usr/bin/python 改为 #!/usr/bin/python2.7)

注意:
还有一种可能导致无法使用yum,就是/usr/bin下的python、python2、python2.7三个文件被改变。
如果上述方法修改默认python版本后无法使用yum只能将python.bak还原;然后新建python3的软链接,例如命名为python3以示区分。

最后:
我已成功安装python3,并且没有出现“注意”中的情况,但是在安装某些需要python3依赖的软件时还会提示我需要python3的依赖而我本机python版本为python2,不知如何解决。

CentOS7默认安装了python2.7.5,当需要使用python3的时候,可以手动下载python源码后编译安装。 下载python(...

竞技宝手机版官网 1

ubuntu的配置方法

2、在python目录中选择python.exe

1、安装python2

多数linux发行版都自带了python2,不与要单独安装。

$ sudo apt-get install python2

竞技宝手机版官网 2

2、安装easy_install for python2

使用wget安装(可能需要root权限)[推荐]**

$ wget https://bootstrap.pypa.io/ez_setup.py -O - | python2

或者先下载ez_install.py,再安装

$ python2 ez_install.py

可以看到,安装脚本ez_setup.py支持两种python版本,如果用python2运行该脚本,安装好的easy_install就是针对python2的。同样的,若使用python3运行该脚本,安装好的easy_install就是针对python3的。 

3、出现下图,全选ok即可

3、安装pip for python2

$ easy_install-2.7 pip

pip2.7 install xxx

版权声明:本文由龙竞技官网发布于龙竞技官网,转载请注明出处:eclipse配置pydev解释器